Opened 10 years ago

Closed 9 years ago

#9261 closed defect (fixed)

dojox.DataGrid autoHeight parameter causes infinite Loop/flickering/100% Cpu utilization

Reported by: vlad Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.3.0
Keywords: grid autoHeight flickering Cc:
Blocked By: Blocking:

Description

Attached is a test file (which is a copy of one of the dojox/Grid tests where autoHeight parameter is added).

Also attached the json store test file. A test store form dojox/grid/tests/support/test_data_date.js can be used. Only make sure that the number of items data store is 5 or less.

Load the provided HTML and try to edit the editable column Message.

You will see a flickering error on FireFox? 3.0.10 (win XP) you will get a strange property not present error in IE7.

Also, and this is a different bug probably (not caused by autoHeight) but in firefox the 'Rich' editor for the 'Message column' is not rich at all.

This issue is critical to my application because I cannot layout the grid without autoHeight. Because my grids live within a <td> table cell and when I add rows to the grid it expands the table cell to fit the content and provides no scrollbars in the surrounding content pane to see any rows below the cell with the grid. So I use autoHeight to constrain the grows of the grid within a table cell.

Attachments (2)

AutoHeight_GRID_PROBLEM.html (4.6 KB) - added by vlad 10 years ago.
test file (still needs a data store file)
test_data_date.js (1.4 KB) - added by vlad 10 years ago.
store file

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by vlad

test file (still needs a data store file)

Changed 10 years ago by vlad

Attachment: test_data_date.js added

store file

comment:1 Changed 10 years ago by Nathan Toone

Milestone: tbd1.5
Owner: changed from Bryan Forbes to Nathan Toone

I can try and take a look at this - but probably not for the 1.4 timeframe.

comment:2 Changed 9 years ago by Nathan Toone

Milestone: 1.5future
Owner: Nathan Toone deleted

Moving my tickets to future, as I am not currently working on them.

comment:3 Changed 9 years ago by evan

Fixed with the same patch for #11101

comment:4 Changed 9 years ago by Douglas Hays

Milestone: future1.6
Owner: set to evan

comment:5 Changed 9 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [22903]) Fixes #9261, 10543, 11101. Add a new boolean to updatePageHeight to avoid a deadlock from calling sizeChange. Proxy commit for evan (IBM, CCLA) !strict

Note: See TracTickets for help on using tickets.