Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#9249 closed defect (wontfix)

HorizontalSlider throws an error in IE8 if value isn't set right

Reported by: redbeard Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.3.0
Keywords: horizontalslider ie8 Cc:
Blocked By: Blocking:

Description

If a dijit.form.HorizontalSlider? is created with an empty value set (e.g. value="", omitting it works fine) IE8 throws an invalid arument error.

I'm not sure the best handling of this, but the problem is at line 174 of dijit/form/HorizontalSlider.js, where the progressBar width is set. My guess is constraining the value of percent would handle it, but there might be a better way I'm unaware of.

Attachments (1)

horizontal-slider-negative-value.html (772 bytes) - added by redbeard 11 years ago.
Throws an error in IE8

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by redbeard

Throws an error in IE8

comment:1 Changed 11 years ago by bill

Resolution: wontfix
Status: newclosed

This doesn't really have anything to do with slider. You've specified value="" for a numeric parameter, so the parser (at least on IE) does a:

new HorizontalSlider({ value: NaN });

... and then slider fails since it isn't setup to handle an NaN value.

It seems more like a user error to me. I don't see that there's anything dojo should be doing differently.

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.