Opened 10 years ago

Closed 10 years ago

#9235 closed defect (duplicate)

Grid: Keyboard Events Resize Columns

Reported by: anthonywatson Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.3.0
Keywords: Grid a11y Cc: Becky Gibson
Blocked By: Blocking:

Description

When I move the focus around from cell to cell in the grid by using the down/up arrow keys, the grid columns resize and the grid cells are no longer uniformly aligned. This happens in both IE 6 and Firefox 3. This behavior can be seen on the following page (and it is also happening in the application I am currently developing):

http://download.dojotoolkit.org/release-1.3.0/dojo-release-1.3.0/dojox/grid/tests/test_edit.html

Change History (4)

comment:1 Changed 10 years ago by Adam Peller

Cc: Becky Gibson added
Component: GeneralDojoX Grid
Owner: changed from anonymous to Bryan Forbes

comment:2 Changed 10 years ago by Becky Gibson

Keywords: a11y added

Just an FYI that this happens in Dojo 1.2.3 as well - before I started making keyboard specific changes.

comment:3 Changed 10 years ago by anthonywatson

I just discovered that this issue appears to only happen when the column header widths are not the same as the column data widths. When I resized the column headers in the 1.3.2 test_edit.html page and then moved the focus with the down arrow key, the problem no longer occurred. Also I tested http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/grid/tests/test_edit.html on 09/09/2009 and it has header and data widths the same to begin with (without manual resizing) and it does not have the problem I described in this bug.

So, I would be willing to say that this bug could be closed since it only happens when column header and data widths are not equal.

comment:4 Changed 10 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

Looks like this is actually a duplicate of #9106

Note: See TracTickets for help on using tickets.