Opened 11 years ago

Closed 11 years ago

#9216 closed defect (fixed)

XmlStore doesn't handle queries correctly with multi-valued attributes.

Reported by: Mignon Belongie Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.4
Component: DojoX Data Version: 1.3.0
Keywords: XmlStore query Cc:
Blocked By: Blocking:

Description

XmlStore? doesn't handle queries correctly when items have attributes with multiple values. I don't have a patch, but the problem is due to _getItems() calling getValue() instead of getValues().

Attachments (1)

XmlStore_multiValuedMatching.patch (4.9 KB) - added by Jared Jurkiewicz 11 years ago.
Patch to enable matching of multivalued attributes (such as one that has multiple tags of the same name wrapping different contents)

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by Jared Jurkiewicz

Milestone: tbd1.4

comment:2 Changed 11 years ago by Jared Jurkiewicz

mignon

I've attached a patch that I believe fixes it (and doesn't break the UT). Can you use it in your environment where you hit a problem and verify it works for you?

Changed 11 years ago by Jared Jurkiewicz

Patch to enable matching of multivalued attributes (such as one that has multiple tags of the same name wrapping different contents)

comment:3 Changed 11 years ago by Jared Jurkiewicz

Side note:

I tested this on FF2, IE 7, and Safari 3.1 with no problems reported.

comment:4 Changed 11 years ago by Mignon Belongie

Yes, it works for me, both in the unit tests and in my code. (Firefox 3.0.10 on Windows Server 2008)

Thanks!

comment:5 Changed 11 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [17479]) Fixing support for multivalued attributes. fixes #9216

Note: See TracTickets for help on using tickets.