Opened 11 years ago

Closed 4 years ago

#9188 closed enhancement (duplicate)

Build application's source files without building dojo source everytime.

Reported by: virsir Owned by: Rawld Gill
Priority: low Milestone: 2.0
Component: BuildSystem Version: 1.3.0
Keywords: needsreview Cc:
Blocked By: Blocking:

Description

I think there is a common usage of dojo build system that is to build the dojo source and the application source in separate layer files.

In development, the dojo source remains stable(and the application dependencies on dojo will be stable at some time), but the application's js files change everyday. So it should be better if the dojo build system can just build the application's files and use the built dojo lib before, because it can save lots of time and make the development process more agile.

Change History (9)

comment:1 Changed 10 years ago by James Burke

Milestone: 1.4future
Owner: changed from alex to James Burke

This is complicated by the transforms done to built files. Probably will not get to it until Dojo 2.0.

comment:2 Changed 8 years ago by bill

Owner: changed from James Burke to Rawld Gill

not sure if these tickets are even valid anymore but assigning to rawld to check

comment:3 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:4 Changed 8 years ago by Rawld Gill

Milestone: future1.8

comment:5 Changed 8 years ago by ben hockey

Rawld don't you have a ticket you opened recently for this same feature in the new builder? Should we close this as a duplicate?

comment:6 Changed 8 years ago by ben hockey

Component: LoaderBuildSystem
Keywords: needsreview added
Priority: highlow

comment:7 Changed 7 years ago by Colin Snover

Milestone: 1.82.0

1.8 is frozen. Move all enhancements to next release. If you need an exemption from the freeze for this ticket, contact me immediately.

comment:8 Changed 7 years ago by bill

I'd suggest wontfix, because the builds run pretty quickly nowadays anyway, assuming copyTests=false.

comment:9 Changed 4 years ago by dylan

Resolution: duplicate
Status: assignedclosed

Duplicate of #13214.
Duplicate of #13214 (favoring the newer ticket as it has a bit more detail on the approach).

The main benefit of this change is not about a build taking too long to build, but rather for organizations that share a common layer of built files, and then just want to build their code that leverages that layer.

Note: See TracTickets for help on using tickets.