Opened 10 years ago

Closed 10 years ago

#9172 closed defect (fixed)

Regression: #8212 causes a problem on IE with multivalue input

Reported by: Jared Jurkiewicz Owned by: James Burke
Priority: high Milestone: 1.3.1
Component: IO Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

This was reported by a co-worker using dojo's io.frame code. The patch to handle multi-valued attributes added in #8212 seems to break on IE.

Testcase coming.

Attachments (3)

test_IFrame.html (830 bytes) - added by Jared Jurkiewicz 10 years ago.
Testfile
blank.html (38 bytes) - added by Jared Jurkiewicz 10 years ago.
blank.html used by testfile.
iframe_io.patch (778 bytes) - added by Jared Jurkiewicz 10 years ago.
Potential patch for this issue to handle cleanup on IE same as we do for safari < 3

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Jared Jurkiewicz

Attachment: test_IFrame.html added

Testfile

Changed 10 years ago by Jared Jurkiewicz

Attachment: blank.html added

blank.html used by testfile.

Changed 10 years ago by Jared Jurkiewicz

Attachment: iframe_io.patch added

Potential patch for this issue to handle cleanup on IE same as we do for safari < 3

comment:1 Changed 10 years ago by James Burke

Milestone: tbd1.4

It looks like we do not need that branching logic for safari < 3 -- all browsers should follow that safari < 3 path, since now with arrays we could have multiple form nodes with the same name. When I just tested, FF is not cleaning up the nodes properly anyway. I have a fix coming soon.

comment:2 Changed 10 years ago by James Burke

Resolution: fixed
Status: newclosed

Hmm, SVN/Trac not working again? Fixed in [17371].

comment:3 Changed 10 years ago by James Burke

Milestone: 1.41.3.1
Resolution: fixed
Status: closedreopened

Need to push this to the 1.3.1 branch

comment:4 Changed 10 years ago by James Burke

Resolution: fixed
Status: reopenedclosed

(In [17372]) Fixes #9172 in the 1.3 branch.

Note: See TracTickets for help on using tickets.