Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#9169 closed defect (fixed)

column reorder problems in RTL

Reported by: carlos26_h Owned by: evan
Priority: high Milestone: 1.5
Component: DojoX Grid Version:
Keywords: bidi Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

Details from Kristina Miceli and Keiichi Yamamoto (IBM):

  1. Start dragging the Name column header to the left.

[image]

  1. When the mouse moves into the Type column, the insert target caret appears on the left of the Description column, not on the left of the Type column. This is unexpected.

[image]

  1. As the mouse cursor move a little further to the left closer to the left border of Type column, the insert target caret appears on the left of the Type column. This is expected.

[image]

  1. Moving further to the left on to the Description header, the insert target caret moves to the left of the Value column. This is unexpected.

[image]

  1. Dropping the name column on this position. Since the caret is at the end of left most column, you would expect the Name column to be placed on the left of Value column. But the Name column is actually placed between Description and Value. This is unexpected.

[image]

Attachments (1)

Snap1.jpg (14.6 KB) - added by carlos26_h 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by carlos26_h

Attachment: Snap1.jpg added

comment:1 Changed 10 years ago by Adam Peller

at least partially duped of #5978 and #9325. There are many problems so it's hard to keep track. We might need to split these out as separate tickets. You can try the patch at #5978 for a partial solution. Please note whether these problems are specific to FF/IE. Thanks.

comment:2 Changed 10 years ago by Nathan Toone

Milestone: tbd1.5

comment:3 Changed 10 years ago by Nathan Toone

Milestone: 1.5future

comment:4 Changed 9 years ago by Adam Peller

Description: modified (diff)
Owner: changed from Bryan Forbes to Evan

I'm removing pieces of this report which are no longer reproducible. If you can reproduce these problems, please open a new ticket with the description.

Works for me: "Grid with row-selecting-bar(rowSelector) cannot work well on RTL. That means, you can not see the row-selecting-bar when dir=rtl"

I think this was fixed elsewhere: "The header and the column do not have the same width on RTL."

comment:5 Changed 9 years ago by Adam Peller

Description: modified (diff)
Summary: dojox.grid works bad when dir=RTLcolumn reorder problems in RTL

moved resize column and cursor issue to separate ticket: #11253

comment:6 Changed 9 years ago by Adam Peller

Milestone: future1.5

comment:7 Changed 9 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [22353]) Patch from Evan and Nate (Wang Pei) fixes #9169 - rtl column reordering !strict

comment:8 Changed 8 years ago by bill

Owner: changed from Evan to evan
Note: See TracTickets for help on using tickets.