Opened 10 years ago

Closed 6 years ago

#9168 closed defect (wontfix)

Images are not rendered on FF 3.5.2.

Reported by: Luis Montes Owned by: Eugene Lazutkin
Priority: high Milestone: future
Component: DojoX GFX Version: 1.3.0
Keywords: gfx images anti-aliasing Cc:
Blocked By: Blocking:

Description

When adding images that need to be adjacent to each other in a container, sometimes lines are displayed that appear to be anti-aliasing artifacts.

This page in IE 7 renders differently at the default zoom level than it does on firefox 3.0.8 and chrome 1.0.154.53. All on Win XP service pack 3.

http://members.cox.net/monteslu/tpic/picture.htm

On IE lines appear where images touch each other in a container.

In firefox it renders correctly at the default zoom level, but lines appear at other zoom levels.

On Chrome all zoom levels render correctly.

Change History (2)

comment:1 Changed 10 years ago by Eugene Lazutkin

Milestone: tbdfuture
Status: newassigned
Summary: Inconsisten GFX rendering of images accross browsers.Images are not rendered on FF 3.5.2.

dojox.gfx does not control how images are rendered, but it uses the underlying native renderers to do so. Nevertheless it looks like this problem was fixed by recent improvements in browsers/dojox.gfx --- I cannot reproduce it.

I am keeping this ticket open because for some reason image samples 2-4 are not rendered at all in Firefox 3.5.2 on all platforms.

comment:2 Changed 6 years ago by Kitson Kelly

Resolution: wontfix
Status: assignedclosed

Considering we don't support Firefox 3.5 anymore (nor does Mozilla), closing ticket. Re-open if anyone wants to actually work on this.

Note: See TracTickets for help on using tickets.