Opened 10 years ago

Closed 8 years ago

#9153 closed defect (worksforme)

Behavior when not passing a second argument to dojo.query for child queries differs across browsers

Reported by: Shane O'Sullivan Owned by: Kris Zyp
Priority: high Milestone: future
Component: Query Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

When a query for direct descendents is executed, e.g.

dojo.query("> .someClass")

is executed, and a second argument is not passed, the behavior is not consistent across broswers.

In FF3, an empty NodeList? is returned, as would be expected. However in IE7 an Error is thrown.

Change History (12)

comment:1 Changed 10 years ago by Adam Peller

Milestone: 1.3.1tbd
Owner: changed from anonymous to alex

is this a regression?

comment:2 Changed 10 years ago by bill

Milestone: tbd1.3.1
Summary: Behavior when not passing a second argument to dojo.query for child queries differs across browsers[regression] Behavior when not passing a second argument to dojo.query for child queries differs across browsers

Yes. This works in 1.2, fails in 1.3 (and trunk).

comment:3 Changed 10 years ago by bill

Description: modified (diff)
Milestone: 1.3.1tbd
Summary: [regression] Behavior when not passing a second argument to dojo.query for child queries differs across browsersBehavior when not passing a second argument to dojo.query for child queries differs across browsers

Oops, I actually meant to write the above comment into #9071, not this ticket.

This isn't a regression, it failed on IE even in 1.2.

(I tested by loading dojo/tests/_base/query.html and running the above command in the firebug lite console.)

comment:4 Changed 10 years ago by bill

Component: GeneralQuery

comment:5 Changed 10 years ago by Shane O'Sullivan

Is anything going to happen with this ticket for 1.4?

comment:6 Changed 9 years ago by James Burke

Milestone: tbd1.5

comment:7 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:8 Changed 8 years ago by bill

Milestone: 1.6future

(sadly) punting seemingly abandoned ticket and meta tickets to future

comment:9 Changed 8 years ago by Chris Mitchell

Owner: changed from alex to dylan

please review/triage

comment:10 Changed 8 years ago by dylan

Owner: changed from dylan to kriszyp

comment:11 Changed 8 years ago by bill

Owner: changed from kriszyp to Kris Zyp

comment:12 Changed 8 years ago by Kris Zyp

Resolution: worksforme
Status: newclosed

Was this fixed already? I can't reproduce this.

Note: See TracTickets for help on using tickets.