Opened 11 years ago

Closed 10 years ago

#9150 closed defect (wontfix)

dojox.grid.DataGrid not extendable if structure defined in markup

Reported by: matteo Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.3.0
Keywords: grid Cc:
Blocked By: Blocking:

Description

extending a DataGrid? is always unsuccessful if the structure is defined declaratively, in HTML markup. However, defining structure programmatically with a javascript object MyStructure?, and setting structure="MyStructure?", is ok. Attached you can find a testcase, taken from a SitePen? example: nothing is shown on screen; the <table> tag seems successfully "widgetified", but no rows are shown. If you add, in <table> tag, structure="layoutCountries", it will work. If you change the dojoType from "TestGrid?" to "dojox.grid.DataGrid?" with or without a structure attribute, it will work the same. (for better trac handling, i've inserted the custom widget directly in the same file, but please note that the bug shows the same with registered widget paths)

Attachments (1)

grid_testcase.html (2.0 KB) - added by matteo 11 years ago.
Testcase for Grid extension (HTML full page)

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by matteo

Attachment: grid_testcase.html added

Testcase for Grid extension (HTML full page)

comment:1 Changed 11 years ago by Adam Peller

Milestone: 1.3.1tbd

Is this a regression?

comment:2 Changed 10 years ago by Nathan Toone

Resolution: wontfix
Status: newclosed

This is not a regression.

This will probably never be supported - due to the fact that the grid is quite complex, and it uses a markupFactory (which needs to be chained) to function as desired.

Closing as wontfix.

Note: See TracTickets for help on using tickets.