Opened 11 years ago

Closed 11 years ago

#9149 closed defect (duplicate)

dojo.date.stamp.fromISOString incorrectly handles TZ offset

Reported by: Littlewood Ed Owned by: anonymous
Priority: high Milestone: tbd
Component: Date Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

dojo.date.stamp.fromISOString is requiring the ':' in the timezone offset. Per the spec, the colon is optional, but without it, fromISOString interprets the offset as seconds.

Attachments (1)

iso.html (597 bytes) - added by Littlewood Ed 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by Littlewood Ed

Attachment: iso.html added

comment:1 Changed 11 years ago by Adam Peller

Component: GeneralDate
Resolution: duplicate
Status: newclosed

formISOString does not implement the full ISO8601 spec, but only a subset, designed for speed. I believe this is accurately represented by the docs for dojo.date.stamp. Optional grammars and many features were left out by design.

See #9028

Note: See TracTickets for help on using tickets.