Opened 10 years ago

Closed 10 years ago

#9116 closed defect (fixed)

IE8: ThumbnailPicker has broken image link

Reported by: sayuri Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit Version: 1.3.0
Keywords: Cc: magicalsayuri@…
Blocked By: Blocking:

Description

http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/image/tests/test_Gallery.html

navNextImg have broken src link.

<img src="[object]" ... />

Because dijit._Widget._blankGif is not string but object. So I set component to Dijit but Dojox.

Any other widget using _blankGif are same, for example dijit.ColorPalette.

Change History (6)

comment:1 Changed 10 years ago by bill

Owner: set to bill
Status: newassigned

Ah I see. blankGif works correctly when it's referenced from within a template, like ${_blankGif}, since toString() is automatically called. So things like the close button on TabContainer works fine. However, it doesn't work when referenced from JS, like img.src = this._blankGif.

I could either change _Widget._blankGif to a String, or call toString() everywhere that it's referenced. I guess changing _Widget._blankGif to a String is less error prone.

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [17378]) Make _blankGif a String rather than a dojo.moduleURL() Object, since it's referenced as a string in many places, from code like img.src = this._blankGif.

Fixes #9116 !strict.

comment:3 Changed 10 years ago by bill

Milestone: tbd1.4

Thanks for pointing out that problem and let us know if that fix fails for you in some way.

comment:4 Changed 10 years ago by hijacker

Resolution: fixed
Status: closedreopened

I have the same issue in dijit.ProgressBar? on line 48 _indeterminateHighContrastImagePath:

dojo.moduleUrl("dijit", "themes/a11y/indeterminate_progress.gif")

adding toString() fixes the issue, though i thought it makes sense to change moduleUrl function instead so that it returns String.

comment:5 Changed 10 years ago by bill

I don't see that error, which browser is it happening on for you and when does it reproduce? I'm not seeing it on IE8 or FF3.5.

(BTW that's really a different issue than this ticket, which is about ThumbnailPicker.)

comment:6 Changed 10 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [20090]) Fix image for indeterminate ProgressBar? in high contrast mode on IE. Fixes #9116, !strict.

Note: See TracTickets for help on using tickets.