Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#9084 closed defect (fixed)

ComboBox: labelFunc test failing

Reported by: bill Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

In robot/test_ComboBox.html on FF3/mac, I get an error in labelFunc:

GROUP "labelFunc" has 2 tests to runbootstrap.js (line 641)
Error: labelFunc was supposed to have a value of Texas. Text is Minnesota, value is Minnesota bootstrap.js (line 641)

Change History (5)

comment:1 Changed 10 years ago by bill

Summary: ComboBox: labelFunc test failing (FF3/mac)ComboBox: labelFunc test failing

Only happens when ComboBox or FilteringSelect is run from the test harness (for running multiple tests)....

Turns out the problem is that the cursor is positioned at a certain position on the screen such that when the labelFunc drop-down is opened (via keyboard commands), it happens to overlap the cursor position. Then the up/down arrows adjust the position in the drop down relative to where the mouse is, rather than relative to the first entry in the drop down.

Simple solution to avoid the test failure is to split mouse and keyboard tests into separate files.

comment:2 Changed 10 years ago by bill

Owner: set to bill
Status: newassigned

comment:3 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

[18629] Split ComboBox and FilteringSelect mouse tests into separate files from the general (ComboBox and FilteringSelect) tests. Solves problem where unfortunate mouse position was interfering w/the keyboard tests.

The new files are named *_a11y.html to follow the existing pattern, although (like the other *_a11y test files) that's a misnomer since they contain all tests that don't use the mouse (keyboard, a11y role, general functionality, and even API tests).

Fixes #9084.

comment:4 Changed 10 years ago by bill

(In [18732]) Fix typo in change to split ComboBox? and FilteringSelect? mouse tests into separate files. Refs #9084.

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.