Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#908 closed defect (fixed)

Unhelpful formulation mentioning SCO vs. IBM

Reported by: A.Kuckartz@… Owned by: anonymous
Priority: lowest Milestone:
Component: Website Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

Your "about" page currently contains this formulation:

"we're just making sure that code that is owned by someone else isn't slipped into the Dojo Toolkit in a way that something like, say, the SCO vs. IBM lawsuit becomes a possibility."

Sorry, but that is nonsense. The SCO Group Inc. has filed the lawsuit as part of an attempt to extort protection money from users and to manipulate the stock. The SCO Group Inc. never had a case and Darl McBride? (CEO) was informed about that before the complaint was filed. It was and is a criminal operation.

There is an informative website regarding that lawsuit and the activities of Darl McBride? and others: http://groklaw.net/

Change History (5)

comment:1 Changed 13 years ago by Tom Trenka

Resolution: invalid
Status: newclosed

Sorry, but by invoking SCO vs. IBM we're making a very clear statement as to why we require a CLA or CCLA on file before even looking at patch submissions, since there seems to be so much confusion about it.

Marking as invalid.

comment:2 Changed 13 years ago by A.Kuckartz@…

Resolution: invalid
severity: blockercritical
Status: closedreopened
Summary: Stupid mention of SCO vs. IBMUnhelpful formulation mentioning SCO vs. IBM

The problem is not that SCO vs. IBM is mentioned.

I fear that the formulation which you are using is needlessly lending credibility to that fraudulent complaint. It would be possible to reformulate the sentence without doing so.

Last year I have encountered a well-meaning journalist who had written an article about SCO. The SCO Group Inc. prominently linked to that article from sco.com. The journalist was shocked when I informed her. Why did SCO link to her article? It turned out that she had unknowingly used a type of argument which also was liked by SCO.

Do you want the Dojo Toolkit website to be misused like that? I do not think so.

comment:3 Changed 13 years ago by Tom Trenka

Priority: highestlowest
severity: criticaltrivial

Seems to me that the text paragraph immediately preceding the lawsuit mention is very clear in its intent, and ensures that the context of the mention of the lawsuit is very clear. The point of the paragraph is to explain the reason we require a CLA on file before even looking at patch submissions; the mention of the SCO vs IBM lawsuit serves to punctuate that reason in a particularly clear manner.

The *only* thing SCO could even conceivably argue is that IBM/Linux et al should have required the same type of agreement.

We don't want the Dojo Toolkit to be misused like that but our feeling is that this does not lend itself to that type of abuse (certainly if IBM, who is the largest company to have filed a CCLA to contribute to Dojo felt strongly about the mention, they'd ask us to take it down). While we appreciate your concern, there's no way this is a critical bug, nor a blocker; and I'd also go so far as to say that unless there is text copy on the site that is offensive, any bugs filed against it will probably end up being marked invalid.

I'm going to keep it open for now to make sure the principals of the Foundation see this bug, but I'm pushing it down to minor as a priority.

comment:4 Changed 13 years ago by Tom Trenka

Resolution: fixed
Status: reopenedclosed

Forwarded onto Alex, who changed the copy in a clearer way. Closing the bug.

comment:5 Changed 13 years ago by A.Kuckartz@…

Thanks for removing the formulation.

Note: See TracTickets for help on using tickets.