Opened 10 years ago

Closed 10 years ago

#9056 closed defect (duplicate)

DialogUnderlay hidden when a Dialog is still shown

Reported by: Michael Stakem Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.3.0
Keywords: Dialog, DialogUnderlay Cc: mstakem@…, bdardel@…
Blocked By: Blocking:

Description

If multiple Dialogs are shown and one Dialog is hidden the DialogUnderlay? is also hidden.

The dijit._underlay object does not seem to track how many or which Dialogs are currently shown so when any Dialog is hidden the DialogUnderlay? hides regardless of whether or not there are still shown Dialogs.

<input type="button" onclick="dijit.byId('GlossaryPopupBoxOne?').show()" value="click for popup 1"/>

<div style="display:none" dojoType="dijit.Dialog" id="GlossaryPopupBoxOne?" title="" execute="">

test popup 1 <input type="button" onclick="dijit.byId('GlossaryPopupBoxTwo?').show()" value="click for popup 2"/>

</div> <div style="display:none" dojoType="dijit.Dialog" id="GlossaryPopupBoxTwo?" title="" execute="">

test popup 2

</div>

OS: Vista Ultimate SP1 32bit

Browser versions: FF: 3.0.8 IE: 7.0.6001.18000 Chrome: 1.0.154.53

Change History (3)

comment:1 Changed 10 years ago by bill

Resolution: duplicate
Status: newclosed

Dup of #7716.

comment:2 Changed 10 years ago by Michael Stakem

Resolution: duplicate
Status: closedreopened

The patch attached to #7716 is for 1.2beta in which every Dialog box has its own underlay object (this._underlay). In 1.3 there is one single underlay object that all Dialog boxes share (dijit._underlay) so the patch does not fix the display bug in the description

comment:3 Changed 10 years ago by bill

Resolution: duplicate
Status: reopenedclosed

This ticket is a duplicate of #7716. I'm not talking about patch attached to #7716, I'm talking about the enhancement described in #7716, which Dustin is working on (not using that attached patch).

Note: See TracTickets for help on using tickets.