Opened 11 years ago

Closed 11 years ago

#9048 closed defect (invalid)

Constructor list for dojox.grid has "See create() for details." under DataGrid, but there is no "create()" method.

Reported by: dkarr Owned by:
Priority: low Milestone: tbd
Component: Documentation Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

On http://api.dojotoolkit.org/jsdoc/1.3/dojox.grid the Constructor list has this:

dojox.grid.DataGrid?(params: Object?, srcNodeRef: DomNode?|String) Kicks off widget instantiation. See create() for details.

The problem is, there is no "create()" method, and as a result of assuming this documentation would be present, there is no documentation here on what properties should be sent in the params parameter.

Change History (1)

comment:1 Changed 11 years ago by dante

Resolution: invalid
Status: newclosed

so this is a common thing. create() is a dijit._Widget method, and is the first public dijit method. All dijit's (and derivatives) accept the same constructor args: (params, optionalNode) ... the 'params' are simply mixed into the instance, so any of the public properties on the api page (typically) can be passed as 'params'. eg:

new Thinger({ title:"blah" });

The "properties" on this page: http://api.dojotoolkit.org/jsdoc/1.3/dojox.grid.DataGrid are the things you can "mix". create() is called for you after the initial instantiation.

Note: See TracTickets for help on using tickets.