Opened 10 years ago

Closed 10 years ago

#9040 closed defect (duplicate)

Declarative dialog dom positionning problem with input hidden

Reported by: vincentastek Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.2.3
Keywords: Dialog input form Cc: vbaudry@…
Blocked By: Blocking:

Description

Hi,

I got the following issue : In a page, I use a global form (just under body). In this form I define a Dialog that contains an input hidden field. When I post my form, the input hidden is never posted. The cause is that the dialog is programmatically placed under body with the following line in Dialog.js :

dojo.body().appendChild(this.domNode);

I suppose this is due to javascript positionning issue in browsers.

My problem is that my application is done a way that won't permit me to put the hidden field out of dialog.

Is there a way to fix that ? Will other normal html input fields I use in Dialog have same problem ? My form is always posted by a javascript submit();

I don't want to do dom moving of all elements or such stuff.

Thanks a lot for your work, and I hope you can show me a way to do that.

Change History (1)

comment:1 Changed 10 years ago by bill

Resolution: duplicate
Status: newclosed

Yup, aware of this problem, see #3300. Will try to fix for the next release. I don't have a good suggestion for a workaround, sorry.

Note: See TracTickets for help on using tickets.