Opened 10 years ago

Closed 8 years ago

#9037 closed task (patchwelcome)

optimize=comments still shrinksafe's dojo.js

Reported by: bill Owned by: Rawld Gill
Priority: low Milestone: 2.0
Component: BuildTools Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

Even when running a build with optimize=comments or optimize=none (not sure if that's a valid option), dojo.js itself still gets shrinksafed. Shouldn't it obey the optimize= parameter?

./build.sh profile=base optimize=comments releaseDir=../../release action=release

Change History (7)

comment:1 Changed 10 years ago by bill

Resolution: invalid
Status: newclosed

Oh nevermind. There's a separate flag called layerOptimize to adjust dojo.js.

It seems strange to have two separate flags but anyway this is clearly operating as intended.

comment:2 Changed 10 years ago by James Burke

FWIW, I would like to change this when we can break APIs, it is an old legacy thing that does not make much sense any more.

comment:3 Changed 10 years ago by bill

Milestone: tbd2.0
Resolution: invalid
Status: closedreopened
Type: defecttask

Oh OK in that case I'll mark this to do in 2.0 (hope I'm not filing a duplicate ticket).

comment:4 Changed 8 years ago by ben hockey

Cc: Rawld Gill added
Keywords: needsreview added
Priority: highlow

Is this still valid with the new builder?

comment:5 Changed 8 years ago by bill

Cc: Rawld Gill removed
Owner: changed from James Burke to Rawld Gill
Status: reopenedassigned

Yes, it still happens (at least when using the command I listed above).

comment:6 Changed 8 years ago by bill

Keywords: needsreview removed

comment:7 Changed 8 years ago by bill

Resolution: patchwelcome
Status: assignedclosed

I think closure will be the compressor of choice going forwards, and we don't have anyone working on shrinksafe, so closing this ticket.

Note: See TracTickets for help on using tickets.