Opened 11 years ago

Closed 10 years ago

#8979 closed defect (fixed)

ondijitclick: clicking by ENTER key sends spurious keypress to textarea (IE)

Reported by: bill Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: Accessibility Version: 1.3.0b3
Keywords: Cc:
Blocked By: Blocking:

Description

Similar to #8978. Clicking a node via the enter key will cause an enter to be sent to whatever gets focus next, in this case a textarea.

I've added a commented out test for this to tests/robot/_Widget-ondijitclick_a11y.html, which should be uncommented once this bug is fixed.

Change History (3)

comment:1 Changed 10 years ago by Becky Gibson

Milestone: tbd1.3.1

comment:2 Changed 10 years ago by bill

Milestone: 1.3.11.4

Talked with Becky about the ondijitclick bugs; agreed to move them to 1.4 since they aren't regressions

comment:3 Changed 10 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [17832]) fixes #8879, #8946, #8951, #8978, #8979, #9304, #9156 rework of ondijitclick event handler. Perform action only on keyup of enter or space. Track object that receives keydown and only invoke action on keyup when target matches the keydown object. Do not use ondijitclick for elements that already have onclick support for enter and space key press (button, links) or when that onclick event will bubble up to a parent element. Thus, changed button and combobutton templates to use onclick rather than ondijitclick. No longer need special case for submit and reset buttons in button.js _onButtonClick(). Updated button_a11y.html test file to include test of submit and reset buttons. Updated widget-ondijitclick.html to again include space and enter key testing. !strict

Note: See TracTickets for help on using tickets.