Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#8933 closed defect (invalid)

dijit.form.Form issue

Reported by: remmons Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

If you have this form tag:

<form id="someFormId" method="post" action="somePage.html">

And make it a dijit.form.Form widget using the following Javascript code:

new dijit.form.Form({ }, dojo.byId("demographicsForm"));

It ignores the method and action tags and defaults the method as a GET. The obvious work around is to add: {method : "post", action : "somePage.html"} to its declaration.

Change History (2)

comment:1 Changed 10 years ago by bill

Resolution: invalid
Status: newclosed

This is intended behavior. Only the parser searches the source DOM node to convert attributes to widget parameters.

comment:2 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.