Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8932 closed defect (fixed)

REGRESSION: XMLStore: In 1.3RC01 dojox.data.XMLStore fails if sendQuery is set to true

Reported by: maddesa Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.3
Component: DojoX Data Version: 1.3.0b3
Keywords: XmlStore sendQuery Cc:
Blocked By: Blocking:

Description

On line 348 in the function _fetchItems:

var localRequest = (!this.sendQuery ? request : null);

will set localRequest to null whenever sendQuery is set to true.

Then on line 485 in _getItems

var deep = request.queryOptions ? request.queryOptions.deep : false;

This will cause an error every time as request will be null.

FIX: instead of null set localRequest to an empty object.

var localRequest = (!this.sendQuery ? request : {});

Change History (6)

comment:1 Changed 10 years ago by bill

Component: GeneralDojoX Data
Owner: changed from anonymous to Jared Jurkiewicz
Summary: In 1.3RC01 dojox.data.XMLStore fails if sendQuery is set to trueXMLStore: In 1.3RC01 dojox.data.XMLStore fails if sendQuery is set to true

comment:2 Changed 10 years ago by Jared Jurkiewicz

Summary: XMLStore: In 1.3RC01 dojox.data.XMLStore fails if sendQuery is set to trueREGRESSION: XMLStore: In 1.3RC01 dojox.data.XMLStore fails if sendQuery is set to true

This problem occurs in 1.3 and up, and is effectively a regression (1.2 and later doesn't have the problem). It's an easy fix, thankfully!

comment:3 Changed 10 years ago by Jared Jurkiewicz

Very confident in this fix and after talking to DougHays?, since this is dojox AND simple, AND regression, its okay to check in. So, committed under changeset (17092)

comment:5 Changed 10 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

comment:6 Changed 10 years ago by Adam Peller

Milestone: tbd1.3

batch move of tickets marked 'tbd' fixed in the 1.3 timeframe

Note: See TracTickets for help on using tickets.