Opened 10 years ago

Closed 10 years ago

#8924 closed defect (duplicate)

dojox.grid.DataGrid bug

Reported by: jli Owned by: Bryan Forbes
Priority: blocker Milestone: tbd
Component: DojoX Grid Version: 1.3.0b3
Keywords: Cc: Nathan Toone
Blocked By: Blocking:

Description

I find a bug under the method _scrollHeader at dojox.grid._FocusManager.

When the DataGrid? is rendered and 'space' remaining under the grid (case 1: no records returned, case 2: the table height exceeds the height of all record rows), an exception is thrown when the user clicks the 'space': "info.n is undefined".

To fix this, I add a statement at the method _scrollHeader:

_scrollHeader: function(currentIdx){

if (currentIdx == 0) return; statement added var info = null;

Change History (2)

comment:1 Changed 10 years ago by Adam Peller

Cc: Nathan Toone added

comment:2 Changed 10 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

This is a duplicate of #8892

Note: See TracTickets for help on using tickets.