Opened 11 years ago

Closed 10 years ago

#8915 closed defect (fixed)

Editor in Dialog: uneditable and cannot set value, using Firefox

Reported by: gemHadar Owned by:
Priority: high Milestone: 1.4
Component: Dijit Version: 1.3.0b3
Keywords: Cc:
Blocked By: Blocking:

Description

An Editor placed in a Dialog is not editable and does not accept a value in Firefox (3.0.7).

Behavior in Safari 4 (OSX), Chrome (Win), IE6: editor is editable, editor content can be set using .attr('value', '...');

Behavior in Firefox (OSX, Win): editor is not editable (cannot enter any text), adding a link gives "dojo.doc is null" error in Firebug, content is not set via .attr('value', '...');

Last time it worked for me was in dojo nightly from 2008-08-09.

Attachments (1)

editor_in_dialog.html (1.8 KB) - added by gemHadar 11 years ago.
based on programmatic Dialog example in test_Dialog.html

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by gemHadar

Attachment: editor_in_dialog.html added

based on programmatic Dialog example in test_Dialog.html

comment:1 Changed 11 years ago by bill

Component: GeneralDijit
Owner: anonymous deleted

Well, Editor in Dialog is broken anyway because of #7716 but this seems like a more basic problem than that ticket.

Although, your test case is a bit suspect in that you should be setting width on the Editor, not the Dialog itself (this is how Dialog works).

But I suspect the real issue is that Dialog hides itself (in postCreate()) before editor gets a chance to initialize which then causes problems for some reason.

comment:2 Changed 11 years ago by bill

Milestone: tbd1.4

comment:3 Changed 10 years ago by bill

Resolution: fixed
Status: newclosed

I tried your example, and reproduced the problem against 1.3, but it's working against the latest code. Not sure when exactly it was fixed.

Note: See TracTickets for help on using tickets.