Opened 11 years ago

Closed 10 years ago

#8913 closed defect (wontfix)

PDF bleeding through the dialog

Reported by: gloewy Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.3.0b3
Keywords: Cc:
Blocked By: Blocking:

Description

When opening a dialog on a windows that has a pdf in an internal frame, the dialog is behind the pdf viewer plugin.

Attachments (1)

test_Dialog_wlc.html (1.2 KB) - added by gloewy 11 years ago.
Test case: Pathed to run in the same folder as the default Dialog test.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by Adam Peller

got a test case?

comment:2 Changed 11 years ago by gloewy

Test case: Place this html tag anywhere in the body of dijit/tests/test_Dialog.html:

<iframe src="http://services.renderx.com/lists/xep-support/att-4243/helloworld.pdf" width="150" height="250"></iframe>

Observe that in 1.2 the dialog correctly appears above the plugin (although the border does bleed), whereas in 1.3rc1 any part of the dialog that overlaps the plugin is obscured.

comment:3 Changed 11 years ago by bill

Priority: normalhigh
Summary: PDF bleeding through the dialog[regression] PDF bleeding through the dialog

Hmm, a regression... I wonder what changed. Well I guess we can trace where it first started failing.

comment:4 Changed 11 years ago by bill

Priority: highlow
Summary: [regression] PDF bleeding through the dialogPDF bleeding through the dialog

It's really better to attach full test cases using the "attach file" button. Also, you really need to list your exact environment where this failed.

I tried your test case in various scenarios:

  • Safari/mac: works fine, no problem with bleeding
  • FF3.0.7/mac: can't load that URL into the iframe, for some reason the server says it's not found
  • IE6/Adobe Reader9.1/win: viewer is grayed out but dialog goes above it, no problem

Changed 11 years ago by gloewy

Attachment: test_Dialog_wlc.html added

Test case: Pathed to run in the same folder as the default Dialog test.

comment:5 Changed 11 years ago by gloewy

As for the environment:

Both ff3.0.7/win xp and Vista/ff3.1b3, Vista/Chrome?

comment:6 Changed 11 years ago by Adam Peller

PDF viewer info? (perhaps relevant here)

comment:7 Changed 11 years ago by bill

Priority: lownormal
Summary: PDF bleeding through the dialogPDF bleeding through the dialog (FF)

This is fallout from [15984]. Maybe should roll back that change.

comment:8 Changed 10 years ago by bill

Resolution: wontfix
Status: newclosed
Summary: PDF bleeding through the dialog (FF)PDF bleeding through the dialog

I spoke too soon. Rolling back [15984] fixes the problem on FF but not on IE, which is hardly useful. I just tested and the problem is happening on both IE7 and IE8, probably IE6 too.

There are a lot of complaints about this problem on http://www.google.com/search?q=pdf+z-index+problem the web, not just for dojo but in general. Unfortunately no solution AFAICT. So I'm forced to mark this as wontfix unless someone can come up with a solution.

Note: See TracTickets for help on using tickets.