Opened 10 years ago

Closed 10 years ago

#8888 closed defect (fixed)

dojo._base.query test fails on 1.3.0rc1 (it was not fault on 1.3.0b3)

Reported by: ferz Owned by: anonymous
Priority: high Milestone: 1.3
Component: General Version: 1.3.0b3
Keywords: Cc:
Blocked By: Blocking:

Description

PASSED test: ../../dojo/tests/_base/query.html::t::doh.is(0, (dojo.query('div#foo').length)); 1 ms Error: test timeout in ../../dojo/tests/_base/query.html

ERROR IN:

(function () {return this.d;})

FAILED test: ../../dojo/tests/_base/query.html 0 ms ------------------------------------------------------------ GROUP "tests._base.NodeList?" has 1 test to run PASSED test: ../../dojo/tests/_base/query.html::t::doh.is(1, dojo.query('+', 'container').length); 1 ms

Mozilla/5.0 (X11; U; DragonFly? i386; en-US; rv:1.9.0.6) Gecko/2009030909 Minefield/3.0.6

Change History (2)

comment:1 Changed 10 years ago by bill

Like #8891, I can't reproduce this either. Tried on two machines and it's working fine for me (FF3.0.7/mac and FF3.0.7/win)

comment:2 Changed 10 years ago by James Burke

Milestone: tbd1.3
Resolution: fixed
Status: newclosed

I believe this was a useragent detection issue: I committed a fix attached to ticket #8895. It is a temporary solution though, need something better, more comprehensive for 1.4, and hopefully we can rely less on useragent detection.

ferz, feel free to test the change by checking out the latest trunk code.

Note: See TracTickets for help on using tickets.