Opened 10 years ago

Closed 6 years ago

#8886 closed defect (patchwelcome)

DataGrid Focus Issue with Select Cell When Always Editing

Reported by: Jarrod Carlson Owned by: Jarrod Carlson
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.3.0b3
Keywords: datagrid cell edit Cc:
Blocked By: Blocking:

Description

I want a column in my grid that does not correspond to a property of the data. Instead, I want to provide a select box with a list of "Action Items" for this particular row. The user should be able to select an item from the list for a given row and as a result of the selection, some behavior will occur.

The problem is that when I click on a cell of type "dojox.grid.cells.Select" that is set to "alwaysEditing=true", the drop down appears and then immediately closes up again as the surrounding cell gains focus. I can click a second time on the select and I get normal behavior, but the first click is not working properly.

This problem appears in at least Firefox 3.0.7 (Mac), Firefox 3.0.6 (XP) and Internet Explorer 7 (XP). This problem is not present in Safari 3 (Mac) and Google Chrome (XP).

I have attached a modified version of /dojox/grid/tests/test_data_grid_edit.html to demonstrate the problem.

Attachments (1)

test_data_grid_always_editing.html (1.6 KB) - added by Jarrod Carlson 10 years ago.
Test file illustrating the "alwaysEditing" problem with Select cells in FF3/IE7

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by Jarrod Carlson

Test file illustrating the "alwaysEditing" problem with Select cells in FF3/IE7

comment:1 Changed 10 years ago by Jarrod Carlson

I also noticed that when all the rows have an "alwaysEditable" column, on startup, only the first row gets the formatNode() method of the cell type executed.

formatNode() appears to be my best opportunity to to dojo.connect to the "onchange" event generated by the select box. When only row 0 does formatCell(), rows 1-n do not get to do dojo.connect() on their own editors. Is that by design or by mistake?

comment:2 Changed 10 years ago by bill

Milestone: 1.3tbd

Will let Bryan pick a milestone for this, probably not 1.3 unless it's a regression.

comment:3 Changed 8 years ago by ben hockey

Owner: changed from Bryan Forbes to Jarrod Carlson
Status: newpending

as of dojo 1.7 the attached test case seems to work. jcarlson if the formatNode issue is still a problem then please attach a test case to demonstrate it.

if there is no response within 14 days, this ticket will automatically close.

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 7 years ago by bill

Resolution: invalid
Status: closedreopened

I tried it on 1.7 for both IE8 and FF11/mac. It fails on both of them, meaning that the first time I click on the select, the drop down appears and then immediately closes up again as the surrounding cell gains focus. I can click a second time on the select and I get normal behavior, but the first click is not working properly. (The drop down shows on mouse down and then disappears on mouse up.)

comment:6 Changed 7 years ago by ben hockey

ok - i closed it because it works for me on IE 8 (XP) with latest from trunk. i just tried FF now and see that it still fails.

comment:7 Changed 6 years ago by bill

DojoX Grid and EnhancedGrid are deprecated in favor of dgrid and gridx.

You should upgrade your code to use one of those two grids.

We will consider patches to the old DojoX Grid code though.

comment:8 Changed 6 years ago by bill

Resolution: patchwelcome
Status: reopenedclosed
Note: See TracTickets for help on using tickets.