Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#888 closed defect (duplicate)

toggler window #3 renders incorrectly

Reported by: adam@… Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

testswidget est_Toggler.html

Toggle the "3" (circle) through multiple cycles, and the popup window #3 pops up but...

On Mozilla and Opera, it always renders incorrectly. On IE, it renders correctly the first time, but not on subsequent toggles

Change History (6)

comment:1 Changed 13 years ago by bill

Milestone: 0.4
Owner: changed from anonymous to bill
Status: newassigned

And on IE7 it causes an exception.

But for the 0.3.1 release, I guess wipe toggle on floating pane is not supported. Will fix for 0.4.

comment:2 Changed 13 years ago by Morris

Satish has been looking at this:

Taking out > node.style.height = 'auto' seems to fix the the issue with Firefox 1.5, IE 6 and Opera 8.54. But the floating window height increases every time you toggle the "3" (circle).

comment:3 Changed 13 years ago by morris

The auto is definitely the cause of the problem - the other floating frames have their height set. When the height is set to auto, the domNode.offsetHeight becomes 2 which causes the other problems. Note that I fixed the exception in IE6 - which has probably fixed it in IE7 too.

comment:4 Changed 13 years ago by bill

Yeah, after [5108], wipeIn()/wipeOut() of fixed length dom nodes doesn't work correctly. Not sure if there's time to fix this for 0.4 but I'll leave it assigned to 0.4 for now.

comment:5 Changed 13 years ago by bill

Resolution: duplicate
Status: assignedclosed

Dup of #704

comment:6 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.