Opened 10 years ago

Closed 10 years ago

#8879 closed defect (fixed)

ondijitclick fires spurious click on refocused element (IE)

Reported by: bill Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: Accessibility Version: 1.3.0b3
Keywords: Cc: Joseph Scheuhammer
Blocked By: Blocking:

Description

See dijit/tests/_Widget-ondijitclick.html on IE.

Focus the div using the tab key, then press enter. The ondijitclick event fires correctly but there's a spurious click event on the button.

See also #3428 for background.

Change History (8)

comment:1 Changed 10 years ago by bill

This is happening in 1.2 too. We take precautions in the code to run the even onkeyup for the SPACE key, to avoid this problem. Not sure why we aren't doing that for ENTER key too. I remember we had long discussions about it though...

comment:2 Changed 10 years ago by Joseph Scheuhammer

Cc: Joseph Scheuhammer added

comment:3 Changed 10 years ago by Douglas Hays

Also, ctrl+space is not allowed to continue in IE but does not fire ondijitclick. Might as well let it do its default behavior.

comment:4 Changed 10 years ago by bill

Milestone: tbd1.4

1.3rc1 has been release; bumping remaining tickets to 1.4 (except for documentation/testing tickets)

comment:5 Changed 10 years ago by bill

Note that DropDownButton/Menu combo is working correctly; it's when focus moves to a native button element that we get problems.

comment:6 Changed 10 years ago by Becky Gibson

Milestone: 1.41.3.1

comment:7 Changed 10 years ago by bill

Milestone: 1.3.11.4

Talked with Becky about the ondijitclick bugs; agreed to move them to 1.4 since they aren't regressions

comment:8 Changed 10 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [17832]) fixes #8879, #8946, #8951, #8978, #8979, #9304, #9156 rework of ondijitclick event handler. Perform action only on keyup of enter or space. Track object that receives keydown and only invoke action on keyup when target matches the keydown object. Do not use ondijitclick for elements that already have onclick support for enter and space key press (button, links) or when that onclick event will bubble up to a parent element. Thus, changed button and combobutton templates to use onclick rather than ondijitclick. No longer need special case for submit and reset buttons in button.js _onButtonClick(). Updated button_a11y.html test file to include test of submit and reset buttons. Updated widget-ondijitclick.html to again include space and enter key testing. !strict

Note: See TracTickets for help on using tickets.