Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8869 closed defect (fixed)

Missing toString() in JsonRestStore.js

Reported by: bobimb Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.3
Component: DojoX Data Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

I'm using dojo 1.2.3 with Firefox (but I don't think this is browser-specific).

I have a Grid, fed by a JsonRestStore (let's call it JRS1). I'm using another JsonRestStore (JRS2) to fill a FilteringSelect placed in one of the cells (let's call it C) of the Grid. Cell C is editable.

The JRS1 field for cell C contains numeric values which are translated into their description by a custom formatter (which uses JRS2).

The problem is: when I double-click on the cell to start the editor firefox complains that, at line 290 of jsonRestStore.js, id has no match() method. This is indeed true as id in my case is an integer.

However the documentation states that identity fields for fetchItemByIdentity() "should be a string or an object that toString() can be called on".

And in fact changing

if(id.match(...

to

if (id.toString().match(...

at line 290 of jsonRestStore.js

fixes the problem.

Change History (3)

comment:1 Changed 11 years ago by Jared Jurkiewicz

Milestone: tbd1.3

comment:2 Changed 11 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

Fixed in changeset: 17008

Note: See TracTickets for help on using tickets.