Opened 10 years ago

Closed 10 years ago

#8842 closed defect (duplicate)

Themeing a <div>: Tooltips not styled correctly

Reported by: thekryz Owned by: nonken
Priority: high Milestone: 1.3
Component: themes Version: 1.2.3
Keywords: Styling div theme FilteringSelect tooltop dialog Cc:
Blocked By: Blocking:

Description

This might concern other elements as well: I am applying my theme not in the BODY tag, but in a div for certain reasons (I have to put my part of the webapp into a template already doing some stuff in the body on its own). According to http://www.dojotoolkit.org/book/dojo-book-0-9/part-2-dijit/themes-and-design/overriding-and-combining-themes it should work fine.

The problem is, that, if I enter a non-valid value into my FilteringSelect?, the Tooltip showing the invalid-message looks like crap (see first Screenshot). That is, because the tooltip element (as many other elements I guess) is automatically added to the BODY element - not the DIV I put the class="tundra" in - and so it comes along unstyled.

The same thing happens with the <option> elements inside my FilteringSelect? - they are selected white on black, as defined in dijit.css, because the theme is not applied (see second Screenshot).

This might actually be a bigger problem, since it could have effects on many elements and I only tested some Dijits here.

I will attach a minimal test file.

Attachments (3)

filteringstyle.html (1.2 KB) - added by thekryz 10 years ago.
minimal Test Case
DojoStyleProb1.jpg (3.5 KB) - added by thekryz 10 years ago.
Shows badly styled tooltip dialog @ FilteringSelect?
DojoStyleProb2.jpg (4.1 KB) - added by thekryz 10 years ago.
Shows badly styled options of FilteringSelect?

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by thekryz

Attachment: filteringstyle.html added

minimal Test Case

Changed 10 years ago by thekryz

Attachment: DojoStyleProb1.jpg added

Shows badly styled tooltip dialog @ FilteringSelect?

Changed 10 years ago by thekryz

Attachment: DojoStyleProb2.jpg added

Shows badly styled options of FilteringSelect?

comment:1 Changed 10 years ago by thekryz

Okay, just found out that this is probably a duplicate of http://trac.dojotoolkit.org/ticket/3300 . Sorry, hadn't seen this before.

comment:2 Changed 10 years ago by bill

Resolution: duplicate
Status: newclosed

Right, it's a known issue but not easy to solve, and documented in that ticket. BTW when writing ticket numbers in bug reports you can just write #3300 (literally typing #3300) and it will auto-link.

Note: See TracTickets for help on using tickets.