Opened 10 years ago

Closed 10 years ago

#8804 closed defect (fixed)

Scrollbars always on in editor

Reported by: baest Owned by: Douglas Hays
Priority: low Milestone: 1.3
Component: Editor Version: 1.3.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

The easiest way to reproduce is:

http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/_editor/test_RichText.html
Compare to
http://archive.dojotoolkit.org/dojo-2008-02-19/dojotoolkit/dijit/tests/_editor/test_RichText.html

This is caused by a height: 100% in the styles loaded in the iframe for html and body (along with some padding). It's doesn't seem necessary to set the height and overflow:auto don't help



Only tested in FF3

Change History (3)

comment:1 Changed 10 years ago by baest

The 100% height happens in dijit/_editor/RichText.js in the function _getIframeDocTxt where "\theight: 100%;" is appended

comment:2 Changed 10 years ago by Douglas Hays

Milestone: tbd1.3
Owner: changed from liucougar to Douglas Hays
Status: newassigned

comment:3 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [16996]) Fixes #8804. Removed height:100% from iframe's body/html style since it caues scrollbars unnecessarily. The rule was added as part of [13054] and is no longer needed.

Note: See TracTickets for help on using tickets.