Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8793 closed defect (wontfix)

Accessibility dijit testing with Zoom Text

Reported by: ontak Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: Accessibility Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

We have conducted some Zoom Text accessibility testing with Dojo dijits and found that for the dijits which dojo puts in the "span" or "div" tags, Zoom Text was unable to move the viewing area (to allow panning) to the widget control. We have tried to add tabindex=0 to the "div" and "span" tags, but this did NOT enable Zoom Text to move the viewing area to the widget (did not pan). Please advise if there is a way to enable panning for dijits requiring "span" or "div" tags

Can an accessibility expert advise us of your Zoom Text testing and/or best practices?

Thanks.

We are using: Zoom Text 9.1 and IE 7.0

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Accessible Dijit Layout</title>
<style type="text/css">
		 @import "./dijit/themes/soria/soria.css";
         @import "./dojo/resources/dojo.css";
</style> 
<script type="text/javascript">
	djConfig = {
		parseOnLoad: true,
		isDebug: false
	};
</script>

<script type="text/javascript" src="dojo/dojo.js"></script>
<script type="text/javascript">
	dojo.require("dijit.layout.ContentPane");
	dojo.require("dijit.layout.TabContainer");
</script>
</head>

<body class="soria">
1] Tab Container (click on the tab to see content)
<div id="tabContainer" dojoType="dijit.layout.TabContainer" 
        style="width:50em;height:10em">
      <div id="LittleRed" dojoType="dijit.layout.ContentPane" title="Little Red Cap" tabindex="0">
      Little Red Cap:  Once upon a time there was a dear little girl who was loved by 
      every one who looked at her, but most of all by her grandmother, 
      and there was nothing that she would not have given to the child. 
      </div>
      <div id="HanselGretel" dojoType="dijit.layout.ContentPane" 
           title="Hansel and Gretel"  selected="true" tabindex="0">
      Hansel and Gretel:  Hard by a great forest dwelt a poor wood-cutter with his wife 
      and his two children. The boy was called Hansel and the girl Gretel. 
      He had little to bite and to break, and once when great dearth fell 
      on the land, he could no longer procure even daily bread. 
      </div>
      <div id="GreenTwigs" dojoType="dijit.layout.ContentPane" 
             title="The Three Green Twigs" tabindex="0">
      The Three Green Twigs:  There was once upon a time a hermit who lived in a forest at the foot 
      of a mountain, and passed his time in prayer and good works, 
      and every evening he carried, to the glory of God, two pails of water 
      up the mountain. 
      </div>
</div>
</body>
</html>

Change History (4)

comment:1 Changed 10 years ago by bill

Milestone: tbd1.4

1.3rc1 has been release; bumping remaining tickets to 1.4 (except for documentation/testing tickets)

comment:2 Changed 10 years ago by Becky Gibson

Resolution: wontfix
Status: newclosed

You will need to provide more details about the ZoomText? testing environment. What type of magnification are you using and how much magnification? Also, dijit makes use of ARIA to identify parts of the page - I don't expect that to affect magnification much, but it is necessary for proper reading. IE 7 does not support ARIA - please test with Firefox 3.5.

I don't know what could be done within the tabcontainer to enable better panning. If you add the tabindex to the tabpanel code as you have done, then, if the user presses tab when a particular tab button has focus, the screen will pan to show the contents of the associated tab panel. I think you want the screen to pan to the tabpanel contents as soon as the tab button gets focus. I'm not sure that is desirable. What if the list of tabs was very long? The tab button could be very far to the right of the tabpanel. In that case I think the user would prefer to arrow through the tab buttons to make a selection and then press tab to interact with the tabpanel contents of the chosen tab.

Marking as wontfix but will respond to additional comments.

comment:3 Changed 10 years ago by ontak

So there were two issues which we had noticed 1) ZoomText? not panning to tab in focus 2) ZoomText? not reading out the text on the tab in focus

I need some clarification on your response. Are you saying that the issue does not lie with the dijit but rather the browser or did you mean the issue lies with either the browser and/or ZoomText?? You had mentioned to test this out with Firefox 3.5. I am wondering was this because you had obtained positive results when tested with Firefox 3.5 and based on that, are saying that the issue is not with the dijit or ZoomText? but it is with the browser only?

The magnification we used was at 4X.

As to your solution about adding tabindex to the tabpanel code, we had tried that it there is still not panning. However, this was tested with IE 6

Please advise, Thank you

comment:4 Changed 10 years ago by BECKY

Sorry, but I'm not an expert zoomtext user and I find it difficult to learn (although I managed JAWS so I should be able to manage zoomtext :). I asked about the testing environment because zoomtext has many options. It seems that you are testing with speech on. I'm not sure what to do about not panning to the tab in focus. We set focus to the tab and JAWS reads the text of the tab correctly. By "tab" I am referring to the tab in a tab list - if this is not what you are referring to, please clarify.

I'm not sure where the problem lies. We have implemented ARIA to try and provide the role of the tab and tab panel so an Assistive technology that support ARIA can provide the additional information to the user. Except for the DataGrid?, we do set focus to items that we want spoken - that should work with zoomtext. Firefox 3.5 has the best support for ARIA. I'm not sure how much of ARIA zoomtext supports at this point. We test all of the dijit widgets with Firefox 3.5 and JAWS 11 and so far all of them work correctly with JAWS (with a few minor bugs that we are addressing). Thus, without more zoomtext experience I really can't answer your questions any better. sorry.

Note: See TracTickets for help on using tickets.