Opened 11 years ago

Closed 9 years ago

#8786 closed defect (wontfix)

AccordionContainer: problem with animation for embedded layout widgets (FF3/win)

Reported by: jfcunat Owned by: bill
Priority: high Milestone: future
Component: Dijit Version: 1.3.0b2
Keywords: AccordionContainer animation Cc:
Blocked By: Blocking:

Description

With Firefox 3 and the test_AccordionContainer.html, I've noticed a buggy display during the animation when the pane with title Embedded Layout Widgets is shown. The embedded layout widgets appears shortly (and are moving) during the animation below the AccordionContainer? (when you show or you hide the pane) There is no problem with IE7 and Safari 3.2

Attachments (2)

a3.html (3.6 KB) - added by bill 10 years ago.
simplified testcase against dojo
a4.html (2.3 KB) - added by bill 10 years ago.
test case not using dojo, showing root gecko bug

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by bill

Milestone: 1.3tbd

Similar to #2643 and #1969, but especially #7104. Perhaps FF3 is also a quirky browser and needs the same fix as IE ([14239]).

comment:2 Changed 11 years ago by bill

Also though, I can't reproduce this on FF3/mac at least. Does it happen for you on test_AccordionContainer.html? PC, mac, or both?

comment:3 Changed 11 years ago by bill

Milestone: tbd1.4

1.3rc1 has been release; bumping remaining tickets to 1.4 (except for documentation/testing tickets)

comment:4 Changed 10 years ago by bill

Owner: set to bill
Summary: [FF3] AccordionContainer problem with animation for embedded layout widgetsAccordionContainer: problem with animation for embedded layout widgets (FF3/win)

I confirmed this happens on FF3/win and FF3.1/win, although FF3/mac is OK.

I'll try to fix.

comment:5 Changed 10 years ago by bill

Milestone: 1.4future

Hmm, well the contents of the AccordionContainer don't actually appear below the AccordionContainer, but rather they corrupt the content that is there, making it slide upwards. This is a gecko bug and I filed a ticket as https://bugzilla.mozilla.org/show_bug.cgi?id=488137

Not sure that there's anything we should be doing about this on the dojo side. We could change AccordionContainer to use overflow: scroll rather than overflow:hidden while doing animations, but that makes weird scroll bars that change height as the animation continues.

Changed 10 years ago by bill

Attachment: a3.html added

simplified testcase against dojo

Changed 10 years ago by bill

Attachment: a4.html added

test case not using dojo, showing root gecko bug

comment:6 Changed 9 years ago by bill

Resolution: wontfix
Status: newclosed

Bug is fixed (on windows) in FF3.6.8. (Although it still happens in FF3.5.11.) Closing this as wontfix since the browser fixed it for us.

Note: See TracTickets for help on using tickets.