Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#8776 closed defect (fixed)

robot debug console partially off screen and has unnecessary scrollbars

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: TestFramework Version: 1.3.0b2
Keywords: Cc: bill
Blocked By: Blocking:

Description

Robot tests run with the debug console positioned 75% vertically, but this is arbitrary and the bottom half is scrolled out of view. Also, due to default margin and border attributes on the BODY/HTML tags, there is an unnecessary horizontal scrollbar.

Attachments (3)

robotconsole.jpg (35.8 KB) - added by Douglas Hays 11 years ago.
newrobotconsole.jpg (24.6 KB) - added by Douglas Hays 11 years ago.
8776.patch (2.6 KB) - added by Douglas Hays 11 years ago.
patch file

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by Douglas Hays

Attachment: robotconsole.jpg added

Changed 11 years ago by Douglas Hays

Attachment: newrobotconsole.jpg added

comment:1 Changed 11 years ago by Douglas Hays

after patch

Changed 11 years ago by Douglas Hays

Attachment: 8776.patch added

patch file

comment:2 Changed 11 years ago by Douglas Hays

Milestone: 1.31.4

Deferring since nothing is broken - just looks better.

comment:3 Changed 11 years ago by bill

Maybe we should check this in now... IE8 is broken due to the mouseMoveAt() problem, in #8956.

This doesn't fix safari 3.2 mac (it still has the same problem shown in the screenshots above) but at least it fixes IE8, plus safari 4 (beta) / win is working too. Didn't try other browsers (except for FF, which has the real firebug for logging, so that doesn't count).

comment:4 Changed 11 years ago by Douglas Hays

Milestone: 1.41.3
Resolution: fixed
Status: newclosed

[17091] Fixes #8776. Resize the robot's test page iframe and console windows such that the container browser window does not need its own scrollbar.

comment:5 Changed 7 years ago by bill

I think this is the root cause of the double scrollbar I listed in #15865:

var emptyStyle = {
        overflow: dojo.isWebKit? 'hidden' : 'visible',
        margin: '0px',
        borderWidth: '0px',
        height: '100%',
        width: '100%'
};
dojo.style(document.documentElement, emptyStyle);
Last edited 7 years ago by bill (previous) (diff)

comment:6 Changed 7 years ago by bill

Component: CoreTestFramework
Note: See TracTickets for help on using tickets.