Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8774 closed defect (fixed)

[PATCH] [CCLA] Problem with horizontal scroll with empty grid, long header.

Reported by: Jared Jurkiewicz Owned by: Bryan Forbes
Priority: high Milestone: 1.3
Component: DojoX Grid Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

Reported by a co-worker of mine:

See attached horizontal_scroll_problem.html for a recreate of this problem. Initially there is one item in the grid and the horizontal scroll bar can be used to scroll to all three columns. When you click the Delete Item button the item is deleted so the grid is empty. The horizontal scroll bar no longer shows up so you can't see the last column in the grid. The problem is that we have certain functionality built into our grid where the user might need to see the column header even if there is no data in the grid. The horizontal scroll bar is needed in this case to see the Population column even if there is no data.

Attachments (3)

horizontal_scroll_problem.html (1.8 KB) - added by Jared Jurkiewicz 11 years ago.
_Scroller.patch (1.1 KB) - added by Jared Jurkiewicz 11 years ago.
Basic patch for this from talking with Bryan Forbes. Makes sure that an empty content view still gets a height of 1px so the scroller will show. Without this, an empty grid can't be scrolled to even see the header.
_Scroller_better.patch (1.1 KB) - added by Jared Jurkiewicz 11 years ago.
Tweaked version of the patch that works better.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by Jared Jurkiewicz

comment:1 Changed 11 years ago by Jared Jurkiewicz

Reproducible as well on 1.3

Changed 11 years ago by Jared Jurkiewicz

Attachment: _Scroller.patch added

Basic patch for this from talking with Bryan Forbes. Makes sure that an empty content view still gets a height of 1px so the scroller will show. Without this, an empty grid can't be scrolled to even see the header.

comment:2 Changed 11 years ago by Jared Jurkiewicz

Summary: Problem with horizontal scroll with empty grid, long header.[PATCH] [CCLA] Problem with horizontal scroll with empty grid, long header.

comment:3 Changed 11 years ago by Jared Jurkiewicz

Feedback from a co-worker on this (they have an app using Grid with 2 views), and it seems to work great for them. They get the scroller eiven for an empty dataset and can scroll-view the header fine.

comment:4 Changed 11 years ago by Jared Jurkiewicz

Found a problem with the patch. Calling _refresh() without true causes it to just set the height to 1, hiding all the data in the grid. Argh. Working on a fix/catch for that.

comment:5 Changed 11 years ago by Jared Jurkiewicz

Fix turns out to be simple, just move the oldPageCount check up a few lines and _refresh() works fine.

Changed 11 years ago by Jared Jurkiewicz

Attachment: _Scroller_better.patch added

Tweaked version of the patch that works better.

comment:6 Changed 11 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [16942]) Fix for horizontal scollbar vanishing. \!strict fixes #8774

comment:7 Changed 11 years ago by Adam Peller

Milestone: tbd1.3

batch move of tickets marked 'tbd' fixed in the 1.3 timeframe

Note: See TracTickets for help on using tickets.