Opened 11 years ago

Closed 11 years ago

#8737 closed defect (duplicate)

dijit.Dialog.destroyRecursive() doesn't remove underlay

Reported by: Scott Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.3.0b1
Keywords: dialog digit.Dialog destroyRecursive Cc:
Blocked By: Blocking:

Description

See attached test case.

Calling destroyRecursive() on an open dijit.Dialog doesn't remove the underlay node. Additionally, calling dlg.hide() and then dlg.destroyRecursive() immediately after doesn't remove it either, probably because it doesn't have time to fade out.

Expected: dlg.destroyRecursive() will remove all associated widget domNodes including the underlay.

Reproduced on FF3.0.6/Mac

Attachments (1)

test_dialog.html (1.0 KB) - added by Scott 11 years ago.
test case

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Scott

Attachment: test_dialog.html added

test case

comment:1 Changed 11 years ago by nic

duplicate of #8672

comment:2 Changed 11 years ago by bill

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.