Opened 11 years ago

Closed 8 years ago

#8691 closed defect (duplicate)

Bug with non-anon function properties

Reported by: Daniel Boelzle [:dbo] Owned by: Richard Backhouse
Priority: high Milestone: future
Component: ShrinkSafe Version: 1.3.0b1
Keywords: Cc: Richard Backhouse
Blocked By: Blocking:

Description (last modified by bill)

shrinksaving the following code:

var foo = {
    bar: function bar() {
        // var bar = arguments.callee; // workaround
        bar.m;
    }
};

results in

var foo={bar:function bar(){
_1.m;
}};

Change History (12)

comment:1 Changed 11 years ago by Daniel Boelzle [:dbo]

Posting the code snippet again since trac seems to have swallowed some linefeed:

var foo = {

bar: function bar() {

bar.m;

}

};

comment:2 Changed 11 years ago by bill

Description: modified (diff)

(FYI, you should surround code samples with triple curly braces. I updated the description to do that.)

comment:3 Changed 11 years ago by Adam Peller

Cc: Richard Backhouse added

comment:4 Changed 11 years ago by bill

Milestone: tbd1.4

1.3rc1 has been release; bumping remaining tickets to 1.4 (except for documentation/testing tickets)

comment:5 Changed 10 years ago by Adam Peller

Owner: changed from alex to Richard Backhouse

comment:6 Changed 10 years ago by Richard Backhouse

comment:7 Changed 10 years ago by Adam Peller

Milestone: 1.41.5

comment:8 Changed 9 years ago by Richard Backhouse

Unfortunately I don't think fixing this one can be considered trivial to fix. I would suggest changing the milestone. I don't think I have the authority to change it.

comment:9 Changed 9 years ago by Adam Peller

Milestone: 1.5future

comment:10 Changed 9 years ago by xMartin

see #11673

comment:11 in reply to:  8 Changed 9 years ago by Remoun Metyas

Replying to rbackhouse:

Unfortunately I don't think fixing this one can be considered trivial to fix. I would suggest changing the milestone. I don't think I have the authority to change it.

Challenge accepted!

Well, I was bitten by this bug, too. I think I managed to solve it; see attachment:ticket:11673:shrinksafe.named_functions.patch on #11673.

comment:12 Changed 8 years ago by ben hockey

Resolution: duplicate
Status: newclosed

Duplicate of #11673.

Note: See TracTickets for help on using tickets.