Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#8687 closed defect (duplicate)

dijit.form.DropDownButton does not position menu correctly in quirks mode on IE8

Reported by: Nathan Toone Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.3.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

This actually appears to be an issue with timing, perhaps. You can see this in effect by removing the doctype declaration in dijit/tests/form/test_Button.html. Opening the popup for a dropdown button positions the menu at the bottom of the page in IE8, instead of being positioned absolutely. In looking at this a bit, it appears that the class "dijitPopup" is not being read by IE8 - though I cannot see why it wouldn't be.

Opening the popup in standards mode (with the doctype) and/or opening it in IE6 and IE7 behave correctly. This issue is limited only to IE8 in quirks mode.

Change History (2)

comment:1 Changed 11 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

This is a duplicate of #8499

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.