Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#8674 closed defect (fixed)

dijit.form.Textarea not inserting value attribute

Reported by: coldfire22x Owned by: bill
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.3.0b1
Keywords: Textarea value Cc:
Blocked By: Blocking:

Description

When passing the value parameter on object creation, the value never finds its way into the textarea.

Attachments (1)

textarea.txt (1.2 KB) - added by coldfire22x 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by coldfire22x

Attachment: textarea.txt added

comment:1 Changed 10 years ago by coldfire22x

I should add that it does appear to work in IE6 but not FF3.0.6 (Windows XP).

comment:2 Changed 10 years ago by coldfire22x

And lastly, that the following does render the textarea correctly:

textarea.attr("value", "Testing 1-2-3");

So it would seem that the problem is only with the object instantiation.

comment:3 Changed 10 years ago by bill

Milestone: tbd1.3
Owner: set to bill
Status: newassigned

Oh I see, it's overwriting the value specified in a constructor like

new dijit.form.Textarea({value: ...}, srcNodeRef);

with the value specified in the srcNodeRef (if one is specified)... even if srcNodeRef is empty and this.value isn't.

comment:4 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [16717]) If a value is specified programmatically, then don't overwrite it with the contents of the srcNodeRef, especially if the srcNodeRef is empty (ex: <div id="mySrcNode"></div>).

Fixes #8674 !strict

comment:5 Changed 10 years ago by coldfire22x

Confirmed that the fix is working -- Thanks

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.