Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#8671 closed defect (fixed)

[regression] Radiobutton: keyboard behaviour of radiobuttons incorrect for IE6 and IE7

Reported by: Joseph Scheuhammer Owned by:
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.3.0b1
Keywords: keyboard a11y Cc: Becky Gibson Douglas Hays
Blocked By: Blocking:

Description

Keyboard a11y of dijit radiobuttons should behave the same way as a standard <input> radio buttons. When tab navigating, focus should go to the first radio selected. Once focus is within the radio group, up and down, or left and right arrows should move between radios in the group, and select the next/previous radio in sequence. If no button in a group is selected, tab should go to the first radio in the group and then arrow keys are used to select and move from radio to radio. Arrow keys do not work in IE6 & 7 but they do work in IE8 and FF.

This is a regression since arrowing works as expected in release 1.2.3. This is similar to #4753.

Change History (5)

comment:1 Changed 11 years ago by Becky Gibson

may be related to / a dup of #8660

comment:2 Changed 11 years ago by Douglas Hays

Milestone: tbd1.3
Resolution: duplicate
Status: newclosed

dup of #8660 caused by [16468]

comment:3 Changed 11 years ago by bill

Resolution: duplicatefixed

(In [16716]) Setting the name attribute after the widget DOM is created, even though it's not attached to <body>, causes subtle problems on IE. Specifically, dojo.query() and getElementsByTagName() don't work. (Even though form submission and dojo.attr(node, 'name') still do work.)

Rollback [16468] and [16474], and implement different solution.

Fixes #8660, #8671, refs #8484 !strict.

comment:4 Changed 11 years ago by Nathan Toone

(In [16785]) Refs #8660, #8671, #8484 - make this change for some of the dojox forms as well to read from the ${nameAttrSetting} value !strict

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.