Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#8666 closed defect (fixed)

RadioButton: form doesn't send default value on IE

Reported by: sayuri Owned by: bill
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.3.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

At attached sample, when click submit only, HTML form send query string "r=a", but Dijit form send empty query string. If click b to change value, HTML form and Dijit form send "r=b".

IE6 on XP is NG, IE7 on Vista is NG, IE8 on Vista is OK, Firefox is OK.

Attachments (1)

8666.html (1.2 KB) - added by sayuri 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by sayuri

Attachment: 8666.html added

comment:1 Changed 11 years ago by bill

Milestone: tbd1.3

Thanks for filing these tickets, Sayuri.

This might be caused by #8660?

comment:2 Changed 11 years ago by sayuri

Sadly, it occurres the following:

  • 1.3.0b1
  • before 8660.patch
  • after 8660.patch

comment:3 Changed 11 years ago by bill

Owner: set to bill
Status: newassigned

Yah, disappointing. This also reproduces with test_Checkbox.html on the "Radio Group #1", where the initial value setting is "talk". I'm looking at it now...

comment:4 Changed 11 years ago by bill

Hmm, well it broke in [16468] for #8484. Apparently doing a node.setAttribute('checked', ...) call on an <input> that isn't yet attached to <body> causes subtle issues like this.

I could switch the order in _Widget.js so it attaches the widget to the DOM before calling applyAttributes(), but that wouldn't help for a simple

new dijit.form.RadioButton({checked: true, name: 'foo'})

without a srcNodeRef specified. Not sure if that ever worked.

comment:5 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

Fixed in [16718].

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.