Opened 11 years ago

Closed 7 years ago

#8637 closed defect (duplicate)

[patch]Key Selection Bug in the DataGrid

Reported by: aizen Owned by: Evan
Priority: high Milestone: 1.5.3
Component: DojoX Grid Version: 1.2.3
Keywords: Grid Bug Key Shift Cc:
Blocked By: Blocking:

Description

Select with <Shift>+<DOWN Arrow> doesn't work correctly. It selects only two rows when we are moving down in the Grid. But <Shift>+<UP Arrow> works fine. You can reproduce it in this test \dojox\grid\tests\test_grid.html I investigate this issue and found bug in _range method (dojox.grid.Selection). fix is attached:

Attachments (2)

Selection.js (4.8 KB) - added by aizen 11 years ago.
Patch_form_of_#8637.patch (552 bytes) - added by Karl Tiedt 7 years ago.
Real patch for current trunk

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by aizen

Attachment: Selection.js added

comment:1 Changed 11 years ago by Adam Peller

Summary: Key Selection Bug in the DataGrid[patch]Key Selection Bug in the DataGrid

no cla, but the patch seems trivial.

comment:2 Changed 11 years ago by Bryan Forbes

Milestone: tbdfuture

comment:3 Changed 7 years ago by Karl Tiedt

Cc: evan added

With this being a trivial patch, is it safe to get committed? The bug still exists today and affects more than just keyboard selection -- (shift+click selection going down a page is broken, but works going up a page)

IE: click row 5 shift+click row 7 shift+click row 9 result: 7-9 selected (not expected)

click row 9 shift+click row 7 shift+click row 5 result: 5-9 selected (as expected)

Changed 7 years ago by Karl Tiedt

Attachment: Patch_form_of_#8637.patch added

Real patch for current trunk

comment:4 Changed 7 years ago by bill

Cc: evan removed
Owner: changed from Bryan Forbes to Evan
Status: newassigned

comment:5 Changed 7 years ago by zhuxw

DataGrid? seems do not support <Shift>+<Arrow Up/Down?> to select rows at all (at least since Dojo1.5). And I can not re-produce the shift+click issue described by ktiedt. Really doubt whether this patch is necessary right now.

comment:6 Changed 7 years ago by Evan

Milestone: future1.5.3
Resolution: duplicate
Status: assignedclosed

Thanks Oliver, so actually this issue(Karl's patch) was already fixed in #16034 with your patch and back ported to 1.5+

So closing as duplicate to #16034

Note: See TracTickets for help on using tickets.