Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#863 closed defect (worksforme)

DebugAtAllCost =true gives error with dictionary constructor

Reported by: Coms Owned by: Tom Trenka
Priority: low Milestone:
Component: General Version: 0.3
Keywords: debugatallcost constructor Cc:
Blocked By: Blocking:

Description

When I use DebugAtAllCost = true and try to create a new Dictionary with

new dojo.collections.Dictionary()

the console in FF reports an error on that above line "is not a constructor".

When I commented the //DebugAtAllCost = true the error went away.

I think I tryed with another object from dojo.collections and the same error appeared.

Change History (4)

comment:1 Changed 13 years ago by Tom Trenka

Milestone: 0.4
Owner: changed from anonymous to Tom Trenka

Can you post an example? I find it easier to figure out what's going on if I see the code that produced the error.

comment:2 Changed 13 years ago by Tom Trenka

Priority: normallow

Spoke with alex on this one; it sounds like you may have used debugAtAllCosts without using the matching dojo.hostenv.writeIncludes() statement. debugAtAllCosts is a switch that prevents Dojo from using XHR to load files that are required; instead, you have to manually use writeIncludes (which uses document.write).

If you didn't use writeIncludes, then dojo.collections.Dictionary probably never loaded, which means it wouldn't exist in the global execution space...which would produce the error you described.

If you could post an example of your code, that would be great.

comment:3 Changed 13 years ago by Tom Trenka

Resolution: worksforme
Status: newclosed

I'm closing this due to no response and not being able to reproduce.

comment:4 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.