Opened 11 years ago

Closed 11 years ago

#8620 closed defect (fixed)

dojo.NodeList test failures on Webkit/latest browsers

Reported by: James Burke Owned by: James Burke
Priority: high Milestone: 1.3
Component: Core Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

From Eugene's work on #8282, some NodeList tests fail in WebKit/FF3.1 because we get back a native NodeList instead of a dojo.NodeList because those browsers do not allow us to modify the constructor value for native NodeLists. Just need to adjust the tests accordingly.

See Eugene's test page in #8282.

Change History (3)

comment:1 Changed 11 years ago by bill

Description: modified (diff)

I'm confused... Eugene's work on #8282 isn't checked into SVN, and isn't scheduled to be checked in until 1.4. Why is this ticket scheduled for 1.3?

comment:2 Changed 11 years ago by James Burke

I was just referencing his ticket because he found the root cause, the constructor comparision. He has a test page that adjusts for that, so I was going to look at just using that test page.

Although we could also consider having dojo.query() return a dojo.NodeList?, converting the native NodeList? to a dojo.NodeList? (technically instance of dojo._queryListCtor). Seems like a slowdown for the QSA branch, but something Alex can speak to better.

For now though I was just going to fix the test case to remove or change the constructor tests to also test for native NodeList?.

comment:3 Changed 11 years ago by James Burke

Resolution: fixed
Status: newclosed

Fixed as part of #8282.

Note: See TracTickets for help on using tickets.