Opened 10 years ago

Closed 10 years ago

#8607 closed defect (fixed)

Regression in [16577]: InlineEditBox broken in FF3 and Safari

Reported by: haysmark Owned by: bill
Priority: blocker Milestone: 1.3
Component: Dijit Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by haysmark)

  1. Update to [16577] or later.
  1. Open themeTester
  1. Click the InlineEditBox? tab
  1. Click "I'm one big paragraph."

The behavior you get is different depending on the browser:

FF3: throws error "setting a property that has only a getter", InlineEditBox? fails to open

Safari: Save/Cancel? buttons render behind the "(HTML after)" text

IE: behaves normally

Change History (4)

comment:1 Changed 10 years ago by haysmark

Description: modified (diff)

comment:2 Changed 10 years ago by haysmark

Description: modified (diff)

comment:3 Changed 10 years ago by bill

Status: newassigned

Ah thanks for catching that; will fix.

comment:4 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [16627]) Don't use 'style' as an attribute name to InlineEditor? since that implies (as per _Widget) that all those properties should be applied to the editor, which is not the case.

Refs #8566, fixes #8607 !strict

Note: See TracTickets for help on using tickets.