Opened 10 years ago

Closed 8 years ago

#8576 closed defect (worksforme)

Mixing percentage with other width units causes the layout to glitch when resizing columns

Reported by: Jared Jurkiewicz Owned by: Bryan Forbes
Priority: blocker Milestone: 1.6
Component: DojoX Grid Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

Grid errors and scrambles view in tests/test_edit_dijit.html when adjusting column width.

I've tried this in FF2 and IE 7. In FF2 (And safari 3.1), the view becomes scrambled after a resize. See attached picture 1.

On IE 7 just clicking on the column to resize it throws JS errors:

Runtime error: Invalid argument

In either case, that testcase fails terribly.

Attachments (1)

Resize_priority_mangles_grid.jpg (159.7 KB) - added by Jared Jurkiewicz 10 years ago.
Screenshots showing after resize of field (in this case priority), grid becomes scrambled.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Jared Jurkiewicz

Screenshots showing after resize of field (in this case priority), grid becomes scrambled.

comment:1 Changed 10 years ago by Bryan Forbes

Milestone: tbdfuture
Summary: Grid errors and scrambles view in tests/test_edit_dijit.html when adjusting column width.Mixing percentage with other width units causes the layout to glitch when resizing columns

This is because the test mixes % widths with em widths and that is failing right now. Because we're so close to 1.3, I don't want to go in and muck around with the resizing code and potentially break it. I'm checking in a fix to change the width of the message to 10 instead of 100%. I'm also going to move this to "future".

comment:2 Changed 10 years ago by Bryan Forbes

(In [16550]) * Changed setValue and setAttribute to use .attr(). !strict

  • Changed from using time since the epoch to Date objects in the test data.
  • Updated test_edit_dijit.html to use 10ems instead of 100% for the message width (refs #8576).

comment:3 Changed 8 years ago by evan

Milestone: future1.6
Resolution: worksforme
Status: newclosed

Not able to reproduce this issue in trunk(by changing the layout with a combination of '100%', '10px', 10 in test_edit_dijit.html) on FF3.0+/IE7+/Safari 5.0, seems to be already fixed, so closing it. We can reopen this if any more hints found.

Note: See TracTickets for help on using tickets.