Opened 11 years ago

Closed 11 years ago

#8542 closed defect (fixed)

dijit.scrollIntoView() fails for certain nodes

Reported by: Joseph Scheuhammer Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: Dijit Version: 1.2.3
Keywords: Cc: Becky Gibson
Blocked By: Blocking:

Description

Discovered while running robot Slider tests: calling dijit.scrollIntoView() on the slider's thumb does not always work for FF3 nor IE8RC1.

Note that sliders have both a domNode and a focusNode. The slider's thumb is its focusNode.

Find attached a test file, "ScrollIntoViewBugDemo.html" that shows the problem. It needs to be located in ".../dijit/tests/form/".

Steps to reproduce:

  1. Load the demo file "ScrollIntoViewBugDemo.html".
  2. Navigate to the buttons at the bottom of the page via the link "Jump to buttons".
  3. Click the "Scroll Slider Thumb Into View" button:
    • the view will scroll, but only about half way up the document.
    • the slider thumb is not scrolled into view.
  4. Navigate back to the buttons.
  5. Click the "Scroll Slider Into View" button:
    • the view scrolls properly to the slider.
    • this scrolls the slider's domNode into view.
  6. Navigate back to the buttons.
  7. Click the "Focus on Thumb" button:
    • the view will scroll to the slider, and the thumb will have focus.

The focus "test" simply shows that the thumb can be scrolled into view by focussing on it.

Platforms tested: FF3.05/Mac, FF3.06beta/WinXp, MineField/WinXP, and IE8RC1/WinXP.

The problem lies somewhere within the addPseudoAttrs() closure inside dijit.scrollIntoView() (".../dijit/_base/scroll.js").

Attachments (1)

ScrollIntoViewBugDemo.html (12.5 KB) - added by Joseph Scheuhammer 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Joseph Scheuhammer

Attachment: ScrollIntoViewBugDemo.html added

comment:1 Changed 11 years ago by bill

Milestone: tbd1.3
Owner: set to Douglas Hays

Marking for 1.3 since this sounds like a regression. (Not sure though.)

comment:2 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [16523]) Fixes #8542 !strict. TD content can sometimes offset from HTML instead of TD.

Note: See TracTickets for help on using tickets.