Opened 10 years ago

Closed 10 years ago

#8539 closed defect (duplicate)

Please promote accessible design in the slider widget

Reported by: wwalker Owned by: Becky Gibson
Priority: high Milestone: tbd
Component: Accessibility Version: 1.2.3
Keywords: Cc: davidb
Blocked By: Blocking:

Description

1) Goto http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Slider.html

2) There are a few sliders (maybe all of them?) that use the valuetext property. The valuetext property should be a human readable version of the valuenow property (see http://www.w3.org/WAI/PF/aria/#aria-valuetext).

I'm noticing that at least two sliders could make better use of the valuetext property. The first slider (the horizontal slider example) exposes the valuetext as a floating point number with many many decimal points. This isn't necessarily human friendly. It might be better to expose the valuetext using the same format shown in the "Slider1 Value:" text area.

The "Fancy HTML labels" slider shows "small" "medium" and "large" for labels, but doesn't expose these via valuetext. Instead, the valuetext is exposed as an integer value. It would be better to expose the "small" "medium" "large" values.

Change History (1)

comment:1 Changed 10 years ago by Becky Gibson

Resolution: duplicate
Status: newclosed

actually the valuetext property has not be implemented in the slider widget. There is an open ticket for that so closing this as a duplicate of #5783

Note: See TracTickets for help on using tickets.