Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#852 closed defect (invalid)

Rich Text Editor Widget - using widget inside of an html textarea doesn't have scrollbar functionality

Reported by: paraujo@… Owned by: alex
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: rich text editor textarea scroll scrollbar Cc:
Blocked By: Blocking:

Description

Bug:

When using the Rich Text Editor in a textarea tag

(eg. <textarea dojoType="Editor"></textarea>)

the scrollbars do not appear as expected when text is entered that exceeds the enclosing container's width/height limits.

Note: When using the Editor inside of a div tag

(eg. <div dojoType="Editor"></div>)

the scrollbars appear as expected when text is entered that exceeds the enclosing container's width/height limits.

Seeing as how the <textarea> tag naturally lends itself to persistance operations, it would be very useful to see the scrollbars work in this context.

Cheers!

-Pedro Araujo Atomogy Corp.

Change History (3)

comment:1 Changed 13 years ago by dylan

Owner: changed from anonymous to alex

comment:2 Changed 13 years ago by anonymous

Resolution: invalid
Status: newclosed

I can't reproduce this, and the behavior that you're looking for seems wrong. If you specify a height property, you should get scrollbars in both cases. If not, it should auto-expand.

If you'd like to re-open this issue, please include browser version and dojo version and build information. Marking invalid.

comment:3 Changed 12 years ago by (none)

Milestone: 0.3.1

Milestone 0.3.1 deleted

Note: See TracTickets for help on using tickets.