Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8507 closed defect (fixed)

resizing vertical splitter in mail demo moves horizontal splitter also

Reported by: Adam Peller Owned by: Bryan Forbes
Priority: high Milestone: 1.3
Component: DojoX Grid Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

Load demos/mail/demo.html Grab the vertical splitter to the right of "Folders" and drag it left and right. Watch the horizontal splitter between the grid and the message content move downwards as you do.

Reproduced on various browsers (IE, FF, Safari)

Change History (5)

comment:1 Changed 11 years ago by Adam Peller

Bill mentions that this might be a miscalculation due to a border width

comment:2 Changed 11 years ago by bill

Component: DijitDojoX Grid
Owner: set to Bryan Forbes

Yes, I believe this is from a grid bug, see the TODO in resize() in _Grid.js:

// TODO: even when Grid is a child of BorderContainer,
// the current code in _resize() calls contentBox() to set the size,
// which is inappropriate since BorderContainer has already done that.
// Should pass changeSize and resultSize to _resize(), and only act on
// changeSize
var sizeBox = {};
dojo.mixin(sizeBox, resultSize || {});
dojo.mixin(sizeBox, changeSize || {});

and also, more to the point, in _resize():

dojo.contentBox(this.domNode, this._sizeBox);	// TODO: should be marginBox() to match dijit behavior

comment:3 Changed 11 years ago by Bryan Forbes

Milestone: tbd1.3
Priority: normalhigh

comment:4 Changed 11 years ago by Bryan Forbes

Resolution: fixed
Status: newclosed

(In [16524]) * Fix for resizing issues. Changed resize code to only resize the domNode if the first argument of resize() is non-null. (fixes #8507 !strict)

comment:5 Changed 11 years ago by Bryan Forbes

(In [16525]) * Fixes grid being too large in the BorderContainer? after resizing fix. (refs #8507)

Note: See TracTickets for help on using tickets.